International Full Size Jeep Association
Home Forums Reader's Rigs Tech Library Trail Stories FSJ-List
International Full Size Jeep Association  

Go Back   International Full Size Jeep Association > Tire Kickin' > Fuel Injection

Thread Tools Search this Thread Display Modes
Old 02-11-2018, 06:20 PM
GreenMachine's Avatar
GreenMachine GreenMachine is offline
Join Date: Jun 14, 2002
Location: Maryville TN
Posts: 229
I didn't notice a big performance gain. I had mine pretty dialed in though before the fitech went on. I wanted it running perfectly with the carb so that I had a good baseline to troubleshoot any issues. My ignition system, fuel tank, fuel lines, intake, exhaust (manifold back) is all new. I have had it shut off on me a couple times and not want to start back for a few minutes but I "think" I have traced it down to a bad connector where the fitech battery wire goes to a fuse block I have on the inner fender. It pulled apart on me when I tugged on it so I'm hoping that was the issue. I drive mine most days when it doesn't rain (have to replace windshield gasket).
Reply With Quote
Old 03-12-2018, 09:32 PM
chuckdds chuckdds is offline
Join Date: Feb 14, 2017
Location: ABQ, NM
Posts: 28

Green machine,

Would you mind sharing your Fitech settings? I rebuilt my engine and installed an EFI 400. Runs OK, but not great. Would love to know how you set everything up with regard to fuel settings, etc.

you can PM me if you would like
1998 Cherokee SE
1985 Grand Wagoneer Limited

1964 Jeepster (wish I still had this one)
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -6. The time now is 03:42 AM.

Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
corner corner