International Full Size Jeep Association
Home Forums Reader's Rigs Tech Library Trail Stories FSJ-List
International Full Size Jeep Association  

Go Back   International Full Size Jeep Association > Tire Kickin' > General FSJ Tech

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 07-01-2010, 02:12 PM
iroc86 iroc86 is offline
Grease Monkey
 
Join Date: Oct 24, 2003
Posts: 268
Cruise control won't accelerate or decelerate, but works otherwise

I think I'm having an issue with the cruise control in my '89 Grand Wagoneer, but I'm not sure what the problem might be. When cruise is engaged, I can't increase (or decrease) my speed using the buttons on the turn signal stalk. I need to completely turn off the system, accelerate (or decelerate) to the new speed, and press the engagement button again. Besides this issue, the cruise control system works great.

For example, if I'm cruising along at 45 mph and hold the R/A button until my vehicle reaches 50 mph, the Jeep will decelerate back down to 45 mph as soon as I release R/A. The same thing happens with the Decel/Engagement button, except in reverse.

Every other cruise system I've used has worked differently... tap R/A to increase by 1 mph, or tap Decel/Engagement to decrease by 1 mph.

I've already swapped out the yellow cruise control box with another one, to no avail. Do I have a problem or is this just the way that AMC designed it?
Reply With Quote
  #2  
Old 07-01-2010, 03:28 PM
jeepjerry's Avatar
jeepjerry jeepjerry is offline
Bleedin' Gasoline
 
Join Date: Oct 12, 2008
Location: Lake Geneva Wisconsin
Posts: 1,781
I think your lucky that it works that much... ...ive never had an AMC or Jeep that the cruise worked on.....
__________________
1977 J-20, 4bbl AMC 360/t-18,33"s.
1976 CJ-5, Healthy AMC 360/t-18, 6" lift, 35"s.
1972 Javelin SST, mild AMC 360. Under cunstruction.

AMC ya!!

Alfano Performance
Kenosha, WI 53142
http://www.alfanoperformance.com
For your AMC performance parts.
Reply With Quote
  #3  
Old 07-01-2010, 04:05 PM
BGW's Avatar
BGW BGW is offline
Master Mechanic
 
Join Date: Jan 02, 2009
Location: Boulder, Colorado/Bozeman, Montana
Posts: 889
Quote:
Originally Posted by iroc86
The same thing happens with the Decel/Engagement button, except in reverse.


Haha I read this really fast and for a second there I thought you were using the cruise control while driving in reverse!

Here is what the manual states:

"To Set Cruise Control
Accelerate to the desired speed, turn the CRUISE switch
to ON, push in the engagement button, then release it.
Take your foot off the accelerator pedal and the set
speed will be maintained, with some variations when
going up or down hills.

To reset Cruise Control to a faster speed, accelerate to
faster speed using the accelerator pedal or R/A
(Resume/Accelerate) button, then push in the engage-
ment button and release it. To reset to a slower speed,
push in the button all the way and hold it there until your
Jeep vehicle slows to the desired speed, then release the
button.

To disengage Cruise Control, apply the brakes lightly,
turn the control to OFF. When the ignition switch is OFF,
the Cruise Control is also disengaged."

Mine works like that, and I think the cruise control was the same in the later model years.

I would think the yellow box would be your problem, but since you've already replaced it, I don't really know.
__________________
1991 Grand Wagoneer, Stock, 99k.

My buddy Sam: "...as far as gas money goes Peter's car is as thirsty as an alcoholic on St. Patricks day..."
Reply With Quote
  #4  
Old 07-01-2010, 09:05 PM
iroc86 iroc86 is offline
Grease Monkey
 
Join Date: Oct 24, 2003
Posts: 268
Yeah, I guess I should be lucky that it even maintains the speed.

Thanks for the excerpt from the owner's manual, BGW. It seems like my system sort of works the way it's supposed to, except for the hold-to-decelerate bit. Hmm...
Reply With Quote
  #5  
Old 07-01-2010, 09:32 PM
jeeper54's Avatar
jeeper54 jeeper54 is offline
350 Buick
 
Join Date: May 25, 2009
Location: Glendale, Az.
Posts: 926
Strangely enough, mine works too. Except that when I engage it, it will speed up about 5 mph.
__________________
Currently without
Formerly
1986 G.W. 360
1986 Eagle Wag
1985 G.W. 360
1984 Eagle Wag
1981 Wag 360
1978 Wag 401
1981 Cherk W/T 258
1966 Wag Super 327
Not counying XJs'.
[Did have a 94 & more recently a '97 GC with 5.2. for awhile. Just not the same! Now have the FSJ blues!
Reply With Quote
  #6  
Old 07-01-2010, 11:44 PM
Mark Wilde's Avatar
Mark Wilde Mark Wilde is offline
Master Mechanic
 
Join Date: Jul 20, 2004
Location: The Great Pacific Northwest!
Posts: 822
When using the buttons to accelerate/decelerate, you have to push the engagement button to lock in the speed. At least I have to on mine. Mine also speeds up 4-5 MPH when engaged. Sucks having to guesstimate, but at least it works!
__________________
90 Grand Wagoneer, 401/727/229, TFI upgrade, MC4350 4V, Edelbrock Performer cam, All-Aluminum Radiator, Razor Conversion, 4" Rusty's all-spring, 31x10.50 BFG TA/KO's...much planned, little time/money, thus she's a PipeDream!
Status: Up and running, but needs attention....
Reply With Quote
  #7  
Old 07-02-2010, 09:38 AM
iroc86 iroc86 is offline
Grease Monkey
 
Join Date: Oct 24, 2003
Posts: 268
I played around with the cruise control some more this morning. Based on what everyone here is saying, I think it's working the way it's supposed to (though different than what I'm used to on every other car I've owned -- it IS a FSJ, after all!).

Mine also seems to speed up about 3-4 mph when cruise is engaged. I've found that to accelerate a small amount, I can press the Decel/Engagement button due to the 3-4 mph offset. Counterintuitive, yes, but it seems to work. Similarly, deceleration requires slowing 3-4 mph below the intended speed and then letting go of the button, which lets the vehicle "catch up" to the intended speed.

From what I've read, I think the 3-4 mph discrepancy could be tweaked by adjusting the Centering control on the cruise box. I might try it and see what happens.
Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cruise Control Driftwood General FSJ Tech 10 12-24-2017 04:07 AM
Edelbrock 1406 Cruise Control JohnIL General FSJ Tech 0 01-24-2008 07:01 PM
Cruise Control JohnIL General FSJ Tech 6 02-05-2006 12:22 PM
cruise control/ vaccum leak? kreb General FSJ Tech 4 03-17-2003 01:51 PM
Yellow cruise control module 89grand General FSJ Tech 1 02-26-2003 04:22 AM


All times are GMT -6. The time now is 04:35 PM.


Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
corner corner