International Full Size Jeep Association
Home Forums Reader's Rigs Tech Library Trail Stories FSJ-List
International Full Size Jeep Association  

Go Back   International Full Size Jeep Association > Tire Kickin' > General FSJ Tech

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 09-14-2012, 08:23 PM
Frank's Avatar
Frank Frank is offline
Gear Head
 
Join Date: Jun 06, 2000
Location: Dunmore, PA USA, "Gateway to the Poconos"
Posts: 658
Electrical Issue!

While trying to park at tonight's football game, I drove ( slowly!) off a curb, nothing bottomed, no bang, nothing. ALL lights dimmed, I smelled a whiff of something burn, ALL lights went out a d the ammeter is just in the orange/red. I happened to be a block from my mechanic's garage, so it's there for the night. It started several times, windows all worked, radio okay, just the lights, inside and out died.

Any ideas on this one? Thanks!


Frank
__________________
Frank
'88 Grand Wagoneer (Almond), "Sluggo" (RIP)
'88 Grand Wagoneer, (Baltic Blue) "Sluggo II" (RIP)
'89 Grand Wagoneer, (Dover Grey) "Sluggo III", keeping my hobby alive!
Reply With Quote
  #2  
Old 09-14-2012, 09:51 PM
Carnuck's Avatar
Carnuck Carnuck is offline
 
Join Date: Feb 12, 2011
Location: Gold Bar, WA
Posts: 6,371
body to motor ground strap may have snapped
__________________
Jeep gauges are for amusement only. Any correlation between them and reality is purely coincidental.
Reply With Quote
  #3  
Old 09-15-2012, 07:15 AM
Rich88's Avatar
Rich88 Rich88 is offline
FSJ Maniac
 
Join Date: Nov 20, 2008
Location: Wilds of Ellington, CT
Posts: 4,182
Quote:
Originally Posted by Frank
While trying to park at tonight's football game, I drove ( slowly!) off a curb, nothing bottomed, no bang, nothing. ALL lights dimmed, I smelled a whiff of something burn, ALL lights went out a d the ammeter is just in the orange/red. I happened to be a block from my mechanic's garage, so it's there for the night. It started several times, windows all worked, radio okay, just the lights, inside and out died.

Any ideas on this one? Thanks!


Frank

Ammeter in an '88? I trust you meant voltmeter.

My theory is that when the lights dimmed, it meant some wire or component grounded out and heavily loaded down the system briefly until it burned out and self-isolated itself from the system. In other words something was acting as a very slow-blow fuse.
Hopefully the alternator is OK and your voltmeter now indicates normal voltage, and you just need to find/fix/repair/replace whatever toasted.
__________________
Jeepasaurus (Wagonus Grandi quadropedus)
88 GW 360-.030 over/2150/727/229/Posi, e-pump, AC (broke), tow package, Monroe Air Shocks, TFI, CTO-Free, AIR-free, oil & tranny coolers, dried knuckle blood all over, GM 350 TBI in a box, waiting...
"You're an FSJ'r when the parts guys memorize your name, phone & credit card#."
Reply With Quote
  #4  
Old 09-15-2012, 08:58 AM
Frank's Avatar
Frank Frank is offline
Gear Head
 
Join Date: Jun 06, 2000
Location: Dunmore, PA USA, "Gateway to the Poconos"
Posts: 658
Ammeter, voltmeter, speedometer... They all flow together after a while!

My mechanic called and without looking at it said it sounded like a fusible link. He will get to it on Monday unless a quick look today would get it up and running. So, it's hurry up and wait for now...

Frank
__________________
Frank
'88 Grand Wagoneer (Almond), "Sluggo" (RIP)
'88 Grand Wagoneer, (Baltic Blue) "Sluggo II" (RIP)
'89 Grand Wagoneer, (Dover Grey) "Sluggo III", keeping my hobby alive!
Reply With Quote
  #5  
Old 09-15-2012, 11:33 AM
aratman aratman is offline
New Member
 
Join Date: Jul 27, 2012
Location: Spokane
Posts: 8
Fuseable link?

Wouldn't that kill all power? How about the light switch or fuse?
Reply With Quote
  #6  
Old 09-15-2012, 12:15 PM
Rich88's Avatar
Rich88 Rich88 is offline
FSJ Maniac
 
Join Date: Nov 20, 2008
Location: Wilds of Ellington, CT
Posts: 4,182
Quote:
Originally Posted by aratman
Wouldn't that kill all power? How about the light switch or fuse?

There are three fusible links, each fusing different "main circuits", or branches. Need to refer to schematics to see which is for what. Ditto for downline fuses.
__________________
Jeepasaurus (Wagonus Grandi quadropedus)
88 GW 360-.030 over/2150/727/229/Posi, e-pump, AC (broke), tow package, Monroe Air Shocks, TFI, CTO-Free, AIR-free, oil & tranny coolers, dried knuckle blood all over, GM 350 TBI in a box, waiting...
"You're an FSJ'r when the parts guys memorize your name, phone & credit card#."
Reply With Quote
  #7  
Old 09-15-2012, 12:35 PM
FSJ Guy FSJ Guy is offline
 
Join Date: Mar 20, 2005
Location: Colorado
Posts: 10,062
Fusible link or some issue with your ignition switch (the one on the top of the column underneath the dash).

Check your heater wiring since you smelled something.
__________________
Ethan Brady
1987 Grand Wagoneer, slightly longer than stock.

www.bigscaryjeep.com

Don't mess with me. I once killed a living hinge.
Reply With Quote
  #8  
Old 09-16-2012, 09:22 AM
Frank's Avatar
Frank Frank is offline
Gear Head
 
Join Date: Jun 06, 2000
Location: Dunmore, PA USA, "Gateway to the Poconos"
Posts: 658
Heater wiring? Even if it wasn't on? I know of some silly wiring instances in these things but if it wasn't on, how could that be a culprit?
__________________
Frank
'88 Grand Wagoneer (Almond), "Sluggo" (RIP)
'88 Grand Wagoneer, (Baltic Blue) "Sluggo II" (RIP)
'89 Grand Wagoneer, (Dover Grey) "Sluggo III", keeping my hobby alive!
Reply With Quote
  #9  
Old 09-17-2012, 02:19 PM
Frank's Avatar
Frank Frank is offline
Gear Head
 
Join Date: Jun 06, 2000
Location: Dunmore, PA USA, "Gateway to the Poconos"
Posts: 658
Fusible Link!

My mechanic found a burnt out fusible link, replaced it and all seems well with the world. He checked the wiring harness and saw no chafing or problems in it as well, so I'm guessing it's 24 year's worth of age rearing its head. Anyway, I'm picking it up after work. Woohoo!


Frank
__________________
Frank
'88 Grand Wagoneer (Almond), "Sluggo" (RIP)
'88 Grand Wagoneer, (Baltic Blue) "Sluggo II" (RIP)
'89 Grand Wagoneer, (Dover Grey) "Sluggo III", keeping my hobby alive!
Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Funny Electrical Issue Suddendeath General FSJ Tech 5 04-25-2012 06:49 PM
Electrical help please! The_Turd General FSJ Tech 2 06-06-2011 11:07 AM
electrical issue JERSEY JOE General FSJ Tech 2 12-28-2010 10:35 AM
Electrical issue 87PlymTD General FSJ Tech 7 07-08-2008 07:35 AM
Electrical Issue mendelo General FSJ Tech 6 06-22-2008 09:24 PM


All times are GMT -6. The time now is 06:30 PM.


Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
corner corner