International Full Size Jeep Association

International Full Size Jeep Association (http://www.ifsja.org/forums/vb/index.php)
-   General FSJ Tech (http://www.ifsja.org/forums/vb/forumdisplay.php?f=10)
-   -   Hydroboost install into a later model wag. (writeup) (http://www.ifsja.org/forums/vb/showthread.php?t=24175)

JeepsAndGuns 01-15-2006 03:46 AM

Well after seeing KaiserMan's writeup on installing hydroboost into his buick powered early 70's J-truck and seeing several diffrences between his and mine I decied to make a write up to show what I did to install hydroboost into my 79 cherokee.

PARTS:
I used a hydroboost assembly out of a 85 chevy K3500. When I bought it, it came with all the lines and the pump. But after compareing the pump to the one on my 401 (will be the same on your 360) there would be no way to use the chevy pump with the jeep bracket. So after doing a little research I find that for the most part, the internals are the same on most all gm style pumps. and the diffrences are the pressure fitting and plunger. So I simply removed the pressure fitting, plunger, and spring from the chevy pump and installed it into my Jeep pump. Now the the master cylinder. I decided to use the one ton m/c for my own reasons (installing larger axles with larger brakes soon) But the stock jeep m/c will bolt right on.

MODS TO THE BOOST UNIT:
The hydroboost units have a "stub" sticking out past the back of the mounting plate. On chevys this doesnt make a diffrence, because the pedal attachment point is far away from the firewall. But in the jeeps (FSJ's) the pedal stud is close to the firewall. So if I was to try and bolt the chevy unit straight to the firewall I would not be able to have a pushrod on the boost unit because of the nub sticking out of the back of the unit. So to make the chevy truck unit work I had to do a couple mods to it. Since I couldnt mount the unit straight to the firewall I had to mount the jeeps aluminum spacer to the hydroboosts mounting plate. Now on these, they both had a slight angle to them, so in order to get the pushrod to line up correctly I had to mount the jeeps spacer as low on the unit as I could. The top of the hole in the spacer is actually touching the top of the nub on the boost unit. I then clamped the spacer to the plate and drilled new holes to match the spacer. (sorry, I dont have any pics of that) But it is pretty mutch straight forward.

Now the next mod I I had to do was shorten the pushrod that attaches to the brake pedal. The chevy one is way too long, plus the end is too big for the stud on the jeep pedal. So I had to find some way to connect the two together. I ended up cutting the rod off a junk booster (stock jeep vaccume one) then useing a spare pedal assembly I had laying around (this helped a lot) I cut the chevy rod and the jeep rod untill I got them to match. I then took the assembly to where I work and had one of our welders TIG weld the rod back together.
IMPORTANT: MAKE SURE YOU DONT MAKE THE ROD TOO LONG, IF ANYTHING MAKE IT A HAIR SHORTER. IF IT IS TOO LONG IT WILL CAUSE THE BRAKES TO BE ON ALL THE TIME AND MAY DAMAGE THE BOOST UNIT.




Now the unit is pretty mutch ready to bolt in. I remove the old booster and m/c. I only removed the m/c because I was installing a new one. If your re useing your stock m/c you should be able to just un bolt it from the old booster and gently pull it out of the way. There should be enough slack in the hard lines.
Now I pretty mutch just bolt the unit on. Since it is heavyer than the vaccume booster, it really helps to have a friend hold the unit in place while you bolt in on from under the dash. I had to make a slight re adjustment of the brake light switch to get it working properly (I made the rod a hair shorter than the old one, see above warning)

Bolted on:



Now for the hoses:
Now you will have two pressure hoses. one from the pump to the unit, and one from the unit to the steering box. (All the hoses are brand new as bought from any parts store) For the line running from the pump to the boost unit I used a stock 85 grand wag hose. I had to do a little re-bending of the hose at the pump end to get it to point at the boost unit, but it works fine. Now for the hose running from the boost unit to the steering box I used the hose from the same truck the boost unit came from. 85 K3500.I didnt have to do anything to the end where it attaches to the boost unit, but the end where it attaches to the steering box I had to do a good little bit of re bending to make it work right, but not all that hard to do.



Now you will also have two return lines. I just simply used a "T" fitting on the line comeing from the box. I put the line comeing from the boost unit on the 90* side of the T fitting. I also added a filter to the system. It was a little high priced (almost $30) but I think it is well worth it, should help the whole system last longer.

Finished:


Bleeding the system.
Now you have everything installed, you need to bleed the system. Here is the way I did it.
I happened to have a spare ps pully laying around, so I placed a 3/8 bolt, nut and washers through it and chucked it into my variable speed drill. I bolted down the pump so it wouldnt move, then filled it with fluid. Useing my drill and a spare short belt, I start spinning the pump slowly, while watching the the level of the fluid. Stopping to top it off when it got low. I kept doing this untill the level stoped getting low. I then install the engine driven belt and tighted down the pump properly. I start the engine and check the fluid and make sure its not too low. I turn the wheel lock to lock a couple times and hit the brake pedal a couple times real lightly. I cut off the engine and check the fluid and toped it off as needed. I hit the brake pedal a couple time to get the pressure (and traped air) out of the acculimator. Start engine agan and do the same steps as before. Shut it off and top off fluid as needed. I think I ended up useing about 2 quarts in total. But the pump, boost unit, and steering gear were all empty. (becasue pump and steering box are new)

Any problems?
So far, no problems, didnt run into anything during the install either.

Whats it like on the test drive?
I pull out and tap the brakes to make sure they are working and almost go through the windshield. I take it out and everything feels good. With my old stock brakes I could not lock up the front tires and the pedal had more travel than I wanted. Now, I dont have to try real hard to make it lock up all four. I have a nice high firm pedal, instead of the low mushy stock feel I had before.

Other info you might want to know:
Yes my cherokee is a 79, so it used flare type fittings on the pump and steering box. The boost unit I got was from a 85 so it had o-ring fittings. As stated above, I used the fitting from the chevy pump. As for the steering box, I found it easyer to just swap in a box from a later model with o-ring fittings. That way I wouldnt have to have a custom hose made that was o-ring fitting on one end, and flare on the other.

Anything I would do diffrent?
If I was to do this agan I would use a adjustable rod end instead of welding on my old one. You can get them from a couple diffrent places I think. All you do to install it, is cut don the old rod, thread it and install the new end. That way you could install the unit without doing any welding.

Just FYI. I will be looking into boost units from diffrent year and model trucks looking for ones that will for the most part bolt on. I will post up with what I find. I am gonna try and do a little work so yall wont have to. :cool:

If yall have any questions please ask away!

DAHoyle 01-15-2006 08:21 AM

Thanks for the Post.

Looks like a detailed, accurate write-up, and I will be sure to consult it when I start my conversion. I'm sure others will as well.

BigGuy45 01-15-2006 08:40 AM

very good write up. ill be saving this one for later.

JeepsAndGuns 01-15-2006 12:26 PM

If you run into any problems or have any questions feel free to ask. I will try my best to help you. I will leave up the pics as long as I can.

KaiserMan 01-15-2006 12:43 PM

Nice write up! How much did the hoses set you back?
I agree with you about using a adjustable rod, if I had to do it again that's the route I would take as well. Even though I did not have an adapter, my push rod looks to be only about 1/2" shorter then yours.
Most likely my pedal sits higher then yours.

JeepsAndGuns 01-15-2006 12:54 PM

Quote:

Originally posted by KaiserMan:
Nice write up! How much did the hoses set you back?
I agree with you about using a adjustable rod, if I had to do it again that's the route I would take as well. Even though I did not have an adapter, my push rod looks to be only about 1/2" shorter then yours.
Most likely my pedal sits higher then yours.

Thats what I am thinking. The older models must have had a diffrent style pedal assembly. I know I couldnt use it without the stock firewall spacer I bolted to it.

As for the hoses, they were like under $20 each, cant remember exact ammount. Just standard off the shelf stuff I got at the local parts store. Nothing special about them. All I did was a little creative re bending of the metal parts to make them line up like they needed to.

jyrus 02-25-2008 09:53 PM

I will post pics of what I have and see what I else I need. I will read your write-up if full. Does this mod. really increasing braking?

Elliott 02-26-2008 01:26 PM

Just a lil heads up... I don't know how hot TIG gets, but if you were to arc weld that rod it goes about 5,000*. Now, just ahead of that joint on the rod you weld (inside the hydroboost) are two rubber o-rings that you can't replace if they fail. Figure that if you are using a GM truck HB you are probably doing so because you can find them plentiful and cheap in the wrecking yards... which also means that those seals are probably old and aren't likely to take high temps real well.
You can also find Astro van hydroboost for relatively cheap in the yards (depending on the yards in your area, some are more expensive in the yards than to buy a reman) and it will require you to also buy/fab a 1" spacer to fit between the mounting plate and your aluminum firewall block, then you have to drill/bush the rod to your 7/16" pedal pin (or just bush if you find one from an ABS rig with the spade shaped rod end).
If you are going to cut and weld the rod that is up to you, lots of folk do it, but you can avoid that whole scenario. You can check the link in my sig for some more info on the Astro units and if you can find a GM truck HB you can surely find an Astro HB (which is also a lil easier on your light duty brakes).

JeepsAndGuns 02-26-2008 05:14 PM

If I was to do it over agan, I would probably thread the rod and install a adjustable end.

jyrus 02-27-2008 07:21 PM

I would like to get a system from Elliot if could get ahold of him


All times are GMT -6. The time now is 01:44 PM.

Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.