International Full Size Jeep Association

International Full Size Jeep Association (http://www.ifsja.org/forums/vb/index.php)
-   Fuel Injection (http://www.ifsja.org/forums/vb/forumdisplay.php?f=94)
-   -   16197427 PCM Idle Issue (http://www.ifsja.org/forums/vb/showthread.php?t=154516)

Billygoat 04-15-2012 08:30 AM

16197427 PCM Idle Issue
 
First the 7747ECM in the same truck DID NOT do this.
Switching to the 7427 made it show up.

Remember I have hydroboost - so don't think vacuum issue!

At idle speeds, if I press the bakes hard or brake and steer so i load up the PS pump it kills the engine, figured that out yesterday, it will sit in gear or park and idle fine, but load that pump some and it just dies, light brakes will make it bounce on the stall saver.

My idle RPMs are now set 800 park/900 gear which is 200 higher than I started with from the ECM and it still does it.
I tried an IAC/TPS reset, that did nothing, I turned the idle screw 1/2 rich and back almost to the same spot, my tps is reading 0.4 volts

I suspect I am over looking another setting?

Ideas?

thanks

JeepsAndGuns 04-15-2012 05:44 PM

Thats really odd. If the PS pump is putting a load on the engine then the stall saver should be kicking in. On mine, I have to try to stall it, actually, I have yet to actually stall the engine since my 7427 swap. The stall saver on it works so much better than the old 7747.
I can put it in first gear and start letting out on the clutch and it just pulls out, stall saver keeps it from dropping too low.

Wonder if it could be a IAC issue, does it seem to be working ok? Does it seem to mabey work slow? Mabey dirty and therefor slow to react? Just thinking out loud.

FSJ Guy 04-15-2012 05:58 PM

What is your base idle in park and drive?

Billygoat 04-16-2012 06:25 AM

The IAC went in new last summer to fix the idle issue I had them with the ECM, after that it was solid.

by base idle is 800park/900gear, however trying to watch the log playback (the 1 thing I don't like about turerpro) I see that target idle does not match that, I see lower targets, I'll have to put the log on real slow playback and see what it is at a point it kills.

I think there must be another setting that is adjusting the idle down, may it is just drops it too low.

I don't like the stall saver settings in the base program I started with (BJDR)
I have not found many 0E bins floating around to start with either, I only have 1 other to compare to (BJKZ) It will rev the engine up 200-300 rpm then drop back down way fast.

I keep questioning i how much to dink with it, since it is a auto tranny program with the tranny section disabled, I wonder how it will react when I get my swap done and it is controlling the tranny???
I have my fuel map dialed in decent enough, I at least feel the 401 will run anyway.

FSJ Guy 04-16-2012 11:33 AM

Can you attach the log? Or PM me and you can email it to me.

You can playback the log and pause it. "SHIFT-[" and "[" will move forwards and backwards "]" in the log.

Billygoat 04-16-2012 12:15 PM

The latest one is an hour, and trying to find the 3 or 4 kills in there really sucks. I'll do a shorter one, now that I figure out how to kill it.

I figured that out on the return trip that I did not datalog - of course!

and FYI, I have my PE set to not turn on since I am working on the base fuel map, and even with just over 1/2 ton (1100 lbs) of cargo in the bed I only had to BIG hills that I felt it could have use a little more punch.
and the J20 rides like a Caddy with a load like that.

FSJ Guy 04-16-2012 03:21 PM

You can send me the long log. You can set up the data tracing graphs and see the "kill" pretty easily when the rmp drops to zero.

Billygoat 04-16-2012 03:28 PM

But how do you get to that point in the playback? The step thru kind of sucks.
Hmm, or duh - export the thing into txt file and open with Excel, search for 0 rpm....

I'll send you the log - probably easier if you pm me your e-mail
(don't know if I have yours or not)

Billygoat 05-24-2012 12:37 PM

Update, after staring at data logs, and checking out my fuel system, I went out on a limb and tossed my Fuel and spark maps in an OD code mask that another member is using (BJYN) and she idled like a happy kitten in park and drive no mater how hard I pushed the steering or brakes, and the sit and idle for park for 45 seconds and die was gone too.
So a little side by side comparisons and I match up a few items that were different, the biggest being the "Integral Idle Control Tables" and "Idle Proportional Action Tables"
Now my OE mask program idles nice and smooth, even parked it at work, took my stuff in and went back out to shut it off, just to see if it would stay running - it did!

FSJ Guy 05-24-2012 01:19 PM

Interesting that there was that much difference. FWIW, I'm running the OD code as my base.

Billygoat 05-24-2012 02:53 PM

Quote:

Originally Posted by FSJ Guy
Interesting that there was that much difference. FWIW, I'm running the OD code as my base.


I know, pretty sure the OD I checked with is the one you started with, it is for a G van or something like that.

I need the OE code for my 4L80E - what sucks is the conversions are way different, so if you open and OD bin with the OE xdf file you get way goofy numbers, so I had to open 2 tunerpro's and do a side by side.


All times are GMT -6. The time now is 03:45 AM.

Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.