International Full Size Jeep Association

International Full Size Jeep Association (http://www.ifsja.org/forums/vb/index.php)
-   Fuel Injection (http://www.ifsja.org/forums/vb/forumdisplay.php?f=94)
-   -   Re: Holley Sniper EFI (http://www.ifsja.org/forums/vb/showthread.php?t=187726)

GWNashville 09-25-2019 08:30 PM

Re: Holley Sniper EFI
 
Hey Guys
I need a little help. I installed a EFI Sniper Hyperspark system and it runs great for about 25 minutes and then it cuts off like someone turned the key off. The fuel pressure is at 59 lbs, I have checked grounds three times. I talked to Holley they thought it might be the coil because it gets really hot. They sent a new one same result. Has anyone had this issue and if so what did you do to fix it. Greatly appreciated. Richard.

acct21 09-30-2019 12:22 AM

Tell us a little more about your setup. Stock/OEM ignition, or the Holley CDI? What kind of fuel pump are you running (in-tank, frame mount, surge tank)?

babywag 09-30-2019 11:29 AM

best bet is either holley tech support forum
or call them.
only a few folks using it here.

that said usually if it just shuts off it's electrical.
if it doesn't fire right back up likely bad component.
if it does fire right back up probably a bad connection somewhere.
since it's time/heat related odds say bad component.

GWNashville 11-29-2020 07:19 PM

Nashville GW
 
Just to let you guys know. Holley sent me a new throttle body. The one I had on the Chevelle only had 22 miles on it. Evidently I was lucky enough to get one that would flood with gas and cut itself off. Which also explained why it ran rich. 4 months later running like a champ.Thought I would let you guys know, in case someone runs into this problem.


All times are GMT -6. The time now is 06:46 PM.

Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.